Hello, Guest the thread was called 1.7k times and contains 15 replies

last post from stevehxyz -

VoLTE user error help!

  • I'm currently on holiday in turkey, and whilst in the pull down settings enabled VoLTE, the system ui immediately died and now I can no longer unlock the phone, I'm only able to access the edge screen, no soft buttons function.


    I can boot into twrp and access the terminal.


    Any ideas how I can dig myself out of the hole?


    I'll write a thousand times, don't fiddle after I sort it.


    I've also got a laptop here so I was thinking of downloading and flashing the latest multi Cisco.


    Any ideas welcome!


    Steve


    Some more information, the other setting I changed at the same time was wifi calling.


    I'm hoping that somebody knows there they are stored so I can pull that file over and revert the settings.


    I've checked build.prop and it doesn't appear to be there.

    Edited once, last by stevehxyz ().

  • Try following adb commands.... should disable it


    settings put global volte_vt_enabled 0


    settings put global wfc_ms_enabled 0


    I would try to reflash proper CSC tool afterwards.. 😀


    Newest version CSC Tool doesnt mean proper version.. have a look at the proper device type / os version..


    If adb wont work i would suggest clearing dalvik/art and cache and installing CSC.. problem is related there when i look at it logically.. but im no oracle.. 😀


    Greets


                                                                                                                             


    Don't take life to serious... nobody will get out alive anyway :cflol:

                                                                                                                             

    Samsung Lover...<3

    PC Modding/Watercooling Enthusiast...:-P

    Can write with 300 Chars/sec B-)

    I love Anime :heyes:

    Roleplayer for like ever :hollow:

    Edited once, last by BioHaZaRD_ch ().

  • Thanks for the response, to add to my woes, I can't unlock the device as none of the softkeys work, I have an unlock pattern set.


    When I do adb devices I see my device with unathorised beside it.


    Any idea what file the settings are in as I should be able to transfer that using twrp and then amend them?

  • Try following...


    Step 1. Plug Android phone to computer with USB... boot to TWRP since there the ADB is standard ON otherwise in normal booted state when you have an unlock pattern applied it would bring you unauthorized ADB state


    Step 2. Open a command prompt window or a terminal window in the ADB installation directory on computer.


    Step 3. Type the command and press enter:

    adb shell rm /data/system/gesture.key


    Step 4. Restart your Android device and you’ll see that the secure lock screen is temporarily gone.


    Now you can at least do diagnosis on the device 😀


                                                                                                                             


    Don't take life to serious... nobody will get out alive anyway :cflol:

                                                                                                                             

    Samsung Lover...<3

    PC Modding/Watercooling Enthusiast...:-P

    Can write with 300 Chars/sec B-)

    I love Anime :heyes:

    Roleplayer for like ever :hollow:

  • No joy with that, no such file.


    I've also been into the TWRP terminal shell with system mounted and tried find . -name gesture.key


    And there's no such file?

  • Just found out where the settings database is stored (/data/data/com.android.providers.settings/databases/settings.db for anybody reading this thread in the future)


    However it's not there on mine, presumably because I don't have debugging enabled.

  • Then i suppose the pattern is related to the SIM card itself.. you normally have to ebter a 4 digit on boot to unlock the SIM ? Or only the pattern ?


    You tried to remove the SIM and boot the device ?


    Other possibility.. i hope you have a backuo of your ohone.. try to restore it and if the phobe works as intended the problem relies on the software side... or merely on the installation .. also you could try only to restore EFS partition.. since there is the IMEI resided in.. you have s8 or s7 ? The fact that your softkeys wont work seems a bit strange to me..


                                                                                                                             


    Don't take life to serious... nobody will get out alive anyway :cflol:

                                                                                                                             

    Samsung Lover...<3

    PC Modding/Watercooling Enthusiast...:-P

    Can write with 300 Chars/sec B-)

    I love Anime :heyes:

    Roleplayer for like ever :hollow:

  • This is the normal unlock screen, I have a pattern set, the systemui is dying and that handles the unlock presumably?


    I've no backup with me here, I can't really wipe the phone here as I need all the data that's on it (primarily for payments!)


    I'm hoping I can find out which db file these settings live in, transfer that file to my pc, open it in sqlite, reset the settings and then transfer it back.

  • Oof.. backup is a must before flashing something new since it can go always something wrong :surprised:


    I dont have much experience with the note 8.. but the problems you say look to me like a corrupt installation.. but since you installed several times from scratch i really cant tell you more advice.. normaly a wipe / fresh install solves most if not all problems :-/..


    The data you have on the phone.. merely app datas are lost anyway.. only custom data is kept (downloads ringtones etc).. did you do a clean flash or a dirty flash ? Since a dirty flash WILL lead to problems if switching rom versions.. allways do a clean flash...😁


                                                                                                                             


    Don't take life to serious... nobody will get out alive anyway :cflol:

                                                                                                                             

    Samsung Lover...<3

    PC Modding/Watercooling Enthusiast...:-P

    Can write with 300 Chars/sec B-)

    I love Anime :heyes:

    Roleplayer for like ever :hollow:

  • Nothing was flashed, the phone was perfect, I decided to turn on Volte and wifi calling, system UI crashed and hasn't restarted since.


    I'm googling to try and find which db holds the global settings as I probably just need to transfer that, update the values then transfer it back, I'm going to transfer all of the db files and see which one it is.

  • Another update for any future readers of this thread, the settings are now stored in /data/system/users/0/settings_global.xml


    But having reset the two in question I'm still dead, I'm about to clear cache and dalvik and see if that improves anything.


    I've also turned off the lockscreen in settings_secure.xml

  • stevehxyz the issue has nothing to do with the volte setting. You are using an old (outdated rom) which had a bug. As soon as you go to another country and get roaming, the UI will look up (because of the clock mods on the lockscreen).


    Solution is to update to any following version (V1.2 or V2.0)


    Another possible "tmp" solution is to remove your sim card, then go to setting and disable roaming clock. And re add the sim card. Have fun :fingerscrossed:

    Check out my most recent inventions at the Please login to see this link.  :D:perfect:

  • And the final solution?


    flash 1.1 again, but with the stock UI which allowed me to login.


    Happy bunny, now no fiddling until I get back home!!!!



    @Please login to see this link. thank you for taking to time to reply


    @Please login to see this link. can I dirty flash 1.2?


    I don't want to go to 2.0 until I get back, just in case!!!!!!

  • Yes you can dirty flash 1.2 :)

    Check out my most recent inventions at the Please login to see this link.  :D:perfect:

Create an account or sign in to comment

You need to be a member to leave a comment.